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Wprowadzenie

Kazdego dnia w naszej pracy spotykamy sie z powtarzaniem wszelkiego rodzaju testéw, co zabiera
nam mnéstwo czasu . Nieraz jakze ciezka jest to praca, gdy musimy zrobié cos$ kilkanascie lub nawet
kilkaset razy. Jednym z programow, ktére mogg w tym pomdéc i ktéry chciatbym opisaé jest OpenSta,
narzedzie stuzgce do mierzenia wydajnosci oprogramowania, ale takze do innych celéw jak np.
mozliwos¢ zautomatyzowanie pewnych akgji.

OpenSta jest ciggle rozwijanym narzedziem darmowym, ktéry mozemy pobrac ze strony
http://opensta.org. Ponadto jesli mamy jakis problem lub pytanie mozemy skorzystac z forum
uzytkownikéw tego programu, ktére rdwniez znajduje sie na podanej stronie.

Pierwsze kroki

Po instalacji uruchamiamy OpenSta Commander. Jest to gtdwny ekran programu, ktéry sktada sie z
drzewa bedacego naszym repozytorium, w ktérym bedg znajdowac sie nasze skrypty i testy.

Struktura sktada sie z trzech katalogdéw: Collectors ,Scripts, Tests. My zajmiemy sie katalogiem Scripts,
w ktérym tworzone sg skrypty w jezyku SCL, oraz katalogiem Tests, w ktérym tworzone s3 testy
korzystajace ze skryptdéw stworzonych wczesniej. Ponadto w gérnej czesci aplikacji miesci sie pasek,
w ktérym dostepne sg rézne opcje - miedzy innymi dos$¢ rozbudowany HELP.
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Rysunek 1 Gtéwne okno programu


http://opensta.org/

Aby utworzy¢ nowy test musimy zaczgé od stworzenia skryptu do testowania. W tym celu wybieramy
z menu File ->New Script . Po stworzeniu klikamy na niego dwa razy i pojawia sie nam okno do

nagrywania skryptu.
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Rysunek 2 Okno do tworzenia skryptow

Ln 0,Col 0

OpenSta moze nagrywac zaréwno po http jak i HTTPS, co na przyktad odrdznia go od JMetera. Jesli
taczac sie z internetem, korzystamy z serwera Proxy, nalezy pamietaé o odpowiedniej konfiguracji
naszej przegladarki.Wyboru dokonujemy z menu Options -> Browser. Jesli chcemy sie tgczyé z

Ustawienia sieci lokalnej (LAN)

§| Ustawienia sieci lokalnej (LAN)

Konfiguracja automatyczna

Automatyczna konfiguracja moze zastgpid ustawienia reczne. Aby zapewnid
uzywanie ustawien recznych, wylacz automatyczng konfiguracie.

|:| Automatycznie wykryj ustawienia
Uzyj skryptu automatycznej konfiguradi

Adres | praxy.xxx.pl

Serwer proxy

D Uzyj serwera proxy dla siec LAN (te ustawienia nie sg stosowane
dla polaczen telefonicznych lub VPM)

[ ok ][ anuiy

]

Rysunek 3 Konfiguracja Proxy

Konfiguracja automatyczna

Automatyczna konfiguracja moze zastapic ustawienia reczne. Aby zapewnic
uZywanie ustawien recznych, wylgcz automatyczng konfiguracie.

D Automatycznie wykryj ustawienia
[Juzyj skryptu automatycznej konfiguracii

Serw ¥

Uzyj serwera proxy dla sied LAN (te ustawienia nie sg stosowane
dla polgczen telefonicznych lub VPN)

| Port: |8|330 | Zaawansowane

[ mie uzywaj serwera proxy dia adresdw lokalnych

Adres: | proxy. Kx.pl

[ ok ][ Ay |

odlegtym serwerem, jest to rowniez mozliwe poprzez odpowiednie ustawienia Options->Gateway.
Niestety tutaj napotykamy na pierwszy problem. Jesli mamy Serwer Proxy ustawiony w ten sposéb
OpenSta nie bedzie potrafit wystartowac . Trzeba przepisac Proxy tak, jak na zamieszczonym obrazku.

Wartg wspomnienia opcjg jest niewatpliwe mozliwos¢ deklaracji zmiennych z gérnego menu
Variable ->Create, gdyz mozemy jeszcze przed nagraniem kodu przygotowac zmienne do
przechowywania interesujgcych nas wartosci. W celu rozpoczecia nagrywania klikamy na czerwony
przycisk lub wybieramy z menu Capture->Record. Otwarta zostaje przegladarka, w ktorej



wykonujemy zaplanowany scenariusz. Po zakonczeniu zamykamy przegladarke lub klikamy przycisk
Stop .
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Include "GLOBAL VRRIRBLES.IHNC™

CHRRACTER*512  USER_AGENT
Integer USE_FRGE TIMERS
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Rysunek 4 Kod programu

Po lewej znajduje sie kod programu, deklaracje zmiennych, informacje o Srodowisku oraz inne dane,
ktdre OpenSta przechwycit. Kod, jak wspomniatem, jest w jezyku SCL (Structured Control Language).
Jesli po nagraniu istnieje potrzeba np. wyciggniecia danych, zrobienia petli lub innych instrukcji,
dopisujemy je bezposrednio w kodzie. Po skoriczonej pracy kompilujemy i jesli nie wystgpity zadne
btedy uruchamiamy skrypt klikajac na zielony przycisk ,,play”.

Jezyk programowania nie nalezy do najprostszych, jednak jesli przyjrzymy sie z bliska mozemy
zauwazy¢ pewne zaleznosci jak np. podstawianie danych pod zmienne itp. Na nastepnym obrazku
pokaze fragment kodu, ktéry zmodyfikowatem w celu wyciggniecia z kodu HTML danych
generowanych przez JavaScript, gdyz OpenSta nagrat to na state i podczas préb ponownego
wykonywania skryptu podstawiat starg wartos¢ niezgodng z aktualnie generowang przez strone.
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ache.struts.taglib.html.TOKEN="+wyjete_dynamiczneé dane+"sboardsiSBO%5D." &
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, WITH "HTML(0)/BODY (1) /BODY (2) /TABLE (1) /TBODY (0} /TR(1) /TD (1) /FORM(1) "=
"/INFUT (0) :ATTRIBUTE:value (2} "

Log "To moja wartosc , Interesujaca mnie wartosc

=
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Rysunek 5 Zmodyfikowany kod programu

|Save the active document Ln 2623,Col 53

Jesli nagrany skrypt nie posiada btedéw powinnismy zobaczy¢ nastepujgcy komentarz :
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! Standard Defines
Include "RESPONSE_CODES.INC™
Include "GLOBAL VARIZBLES.INC™

CHRRACTER*512  USER_AGENT

Integer USE_PAGE_TIMERS ol
4 > HTHML |Structure] HTHML Tree | Server Header EIientHeaderJ

1-1 :[26]: SYNCHRONIZE j
1-1 :[26]:21]1 requests synchronised.
1-1 :[28]:5T0P TIMER: T_TEST
1-1 :[29]:TRerdExit, step 0: Cancelled all requests. Now walting for the terminating script regquest:
1-1 :[29]:TRerdExit, step 1l: Script regquests completed. Disconnecting all clients.
1-1 :[29]:TRerdExit, step 2: Script clients disconnected.
1-1 :[259]:TOF execution is over.
L!_Script Completed Successfully. '
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Rysunek 6 Kompilacja kodu

Po kompilacji, mozemy znalez¢ w kodzie funkcje ,,Get” najsé na nig kursorem i gdy uaktywni sie z6tta
strzatka w gérnym menu nacisnga¢ jg. Zobaczymy strone w podgladzie w prawej kolumnie.
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-1 :[54]:SYNCHRONIZE

-1 :[54]:211 regquests synchronised.

-1 :[56]:3TCP TIMER: T TEST1

-1 :[57]:TRcrdExit, step 0: Cancelled all requests. Now waiting for the terminating script request:J

-1 :[57]:TRcrdExit, step l: Script regquests completed. Disconnecting all clients.

-1 :[537]:TRcrdExit, step 2: Script clients disconnected.

-1 :[57]:TOF execution is over.
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Rysunek 7 Uruchomienie podgladu strony po prawej stronie

Teraz mozemy zobaczy¢ strukture HTML, dane o serwerach i inne moggce nam pomadc informacje.

Mozemy tez przejs¢ do kodu HTML i klikajgc prawym przyciskiem myszy na interesujgcy nas kod
stworzy¢ zmienne, ktdre bedg nam wyciggac elementy z modutu DOM z kodu (moze to nam postuzyé
do wyciggania réznych informacji np. tworzonych przez jezyk JavaScript),
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Definitions 0 U E (

! Standard Defines

Include "RESPONSE_CODES. INC™ Polska
Include "GLOBAL_VARTABLES. INC™
CHARACTER*512  USER_AGENT Szukanis zaawansowane
Integer USE_PAGE TIMERS = Lstaiianis,
CHARACTER*256  MESSAGE Szukaj w Google Szczeslwy traf Hamedzia jemvhowe

& Szukajw Intemecie © Szukaj na stronach kategorii: jezyk polski
Timer T_PLAYED_GAMES

CHARACTER*1024 cookie_2_0
CHARACTER*512  Smolar ,LOCAL
ZTacznij swij dzief z Google.
CONSTANT DEFAULT HEADERS = "Host: wmm Ustaw Google jako swajs strong startows,
"Proxy-Connection: Keep-aliwe®J™ &
"User-hgent: Mozilla/4.0 (compatible; MI
CONSTANT 5_cookie_l1 0 =&
"PREF=ID=3c8500bd6e3fdo29: TH=1207811721: LM=1207¢
s

Programy reklarmowe - ¥yszystko 0 Google - Szukamy Pracownikdw - Google com in English
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Rysunek 8 Podglad strony

Klikajac na jedng z zaktadek podgladu strony mozemy zobaczy¢ catg strukture strony, elementy oraz
wszystkie wartosci.
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! Standard Defines
Include "RESPONSE_CODES. INC™
Include "GLOBAL WARIAELES. INC™
CHARACTER* 512 TSER_AGENT
Integer USE_PAGE_TIMERS
CHARACTER* 256 NEZSAGE
Timer T_PLAYED_GAMES
CHARACTER*1024 cockie_2 0
CHARACTER® 512 Smolar ,LOCAL
CHARACTER*S51Z Lukaszz ,LOCAL
CHARACTER* 512 submitiame ,LOCAL
CHARACTER*S512 Dlugosc_Pola ,LOCAL
CONSTANT DEFAULT_HEADERS = "Host:

Addressing,
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2-E TR
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|DIugDsc_F'oIa

(]
»

HTMLI Stucture HTML Tree I Server Header I Client Header |

name : g
size 1 55
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=
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Rysunek 9 Struktura strony

Ponadto klikajac na zaktadke HTML Tree mozemy znalezé w kodzie interesujaca nas wartosé, po czym
klikajgc prawym przyciskiem myszki podstawic jg bezposrednio pod zmienng do naszego kodu po

lewej stronie zaktadki.
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Rysunek 10 Podstawianie wartosci z HTML pod zmiennga




Teraz mozemy zajac sie tworzeniem testu. Powracamy do gtéwnego menu programu i klikamy z

menu File-> New Test-> Tests . Po utworzeniu dwukrotnie klikamy na ikone testu w drzewie po czym

pojawia sie nam menu testowe.
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Rysunek 11 Okno do tworzenia testéw

Nastepnie rozwijamy liste ze skryptami, wybieramy stworzony wczesniej skrypt i przeciggamy go do
pola Task. Pola te mamy podzielone na kolumny w ktére mozemy dodawac kilka skryptéow. Oznacza
to, ze jesli dodamy w tym samym wierszu - ale réznych kolumnach - kilka testdw, wszystkie zostang
wykonane w tym samym czasie, natomiast dodanie skryptéw w réznych wierszach stworzy nam

scenariusz przejsé jedno po drugim.
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Rysunek 12 Okno do konfiguracji testow

W konfiguracji testdw mamy kilka pél, ktérymi mozemy sterowac . Pole Start stuzy do ustawiania
czasu, kiedy test ma sie wykonac ( bezposrednio, opdzniony i zaplanowany ). Kolejnym ustawieniem
jest ilos¢ wirtualnych uzytkownikow dla kazdego zadania. Uzytkownikéw tych mozemy podzieli¢ na
rozne kategorie np. dajemy catkowitg ilos¢ VU 1200, przydzielamy po jednym uzytkowniku dla
,Timer Results” i dla ,HTTP results”.

T azk. Termination On Completion -
turnber of times each uger will run this tagk (iterations] |4 _III
[relay between each iteration Fived Delay -
Delay =

o=

Rysunek 13 Ustawienie taskow

Generalnie, jesli chodzi o uzytkownikéw, to mozemy tez zaprogramowac w petli w kodzie np.
zaktadanie konta na stronie i obserwowac, jak dtugo to trwa patrzac na rdznego rodzaju raporty,
ktdre opisze pdzniej. Teraz naciskamy na przycisk run i test zaczyna dziata¢. Podczas wykonywania sie
testu mozemy na biezgco obserwowaé, co sie tam dzieje. Stuzy do tego zaktadka Monitoring. Po
wejsciu na nig, gdy test jest wykonywany mozemy zaznaczy¢ np. zaktadke Summary i obserwowac,
jak test jest wykonywany.( Nie jest to jednak niestety przyjazne dla uzytkownika, gdyz informacje nie
do konca sa czytelne). Ponadto mozemy weryfikowaé, czy podczas wykonywania nie wystepuje zaden
btad.
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Rysunek 14 Raporty podczas wykonywania sie testu

Po wykonaniu sie testu nie pozostaje nam nic innego, jak zaktadka Results . Znajduje sie tam
mndstwo raportéw, z ktérych mozemy dowiedzie¢ sie miedzy innymi o konfiguracji, czasach
wykonywania iteracji, przeanalizowac¢ wykresy i przegladac inne opcje.
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Ik 13/04/08 00:47:32 | 192_168_1_2_D0OO0B44  00:00:00.000 1 0 D HITP Monitored Bytes /e
- O Indude 13/04/08 00:47:42 | 192_168_1_2_00000B44  00:00:00.190 1 0 [ HTTP Response Time v hun
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g 13/04/08 00:47:52 | 192_168_1 2 000D0B44  00:00:00.153 1 1 E e e e et
3 13/04/08 00:48:02 | 192_168_1_2 D0OO0E44 00:00:00.136 1 10 O Timer List
z 13/04/08 00:48:12 | 192_168_1_2_00000B44 00:00:00.119 1 17 [ Timer Values v Active Users
b 13/04/08 00:48:22 | 192_168_1_2_00000B44  00:00:00. 108 1 23 O Timer values v Elapsed Tim
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§ 13/04/08 00:48:42 | 192_168_1_2 D0000B44  00:00:00.098 1 % — )
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Rysunek 15 Rezultaty po wykonaniu testu

Raporty wybieramy zaznaczajgc w drzewie po prawej stronie checkbox obok interesujgcej nas opcji.
Mysle, ze powinnismy zapoznac sie z kazdg opcjg w celu znalezienia potrzebnych nam informacji oraz
zapoznania sie z wykresami pokazujgcymi rézne zaleznosci. Jesli podczas wykonywania scenariusza
wystgpig btedy, zostanie automatycznie stworzony log z opisem btedéw. Ponizej kilka screendéw z
raportéw.



g HTTP Data List:- 13-04-2008 00-47-32.001

@ HTTP Response Time v Numbe...-Eln

# Time Stamp User I URL Fesponze T... | Responze C... | Reply Size -~

4 20080413 004732 29 GET http:/vweng... 1156 200 7081 5000 T T S000
5 0080413004732 210 GET http: /v g... 1203 200 7074

3 0080413004732 24 GET http: /v g... 1265 200 074 4500 + 1 4500
7 0080413004732 23 GET http: v g... 1312 200 £314

8 0080413004732 211 GET http:fvmng... 1312 200 074 4000 1 L 2000
g 0080413004732 33 GET http: /v g... 1343 200 073 .

10 20080413 004732 28 GET http: /v g 2031 200 7081 i acon 4 | 2500
n 0080413004732 31 GET http: /v g... 2156 200 074 =

12 0080413004732 212 GET http: /v g.. 2250 200 7081 g o0 4 | 2000
13 0080413004732 27 GET http:fvmng... 2312 200 £320 =

14 0080413004732 24 GET http: /v g, 2484 200 6314 B .
15 0080413004732 25 GET hitp:/Aown. g 2593 200 7074 £ 2500 7 2500
16 0080413004732 441 GET http: /v g... 3830 200 074 o

17 0050413004732 44 GET hitp:/wwong... 3575 200 7074 & 2000 + T 2000
18 0080413004732 411 GET http: /v g 3953 200 7081 o

19 2008041300:47:32 4419 GET http: /v g 4046 200 6314 £ 1200 4 '+ 1500
0 0080413004732 32 GET http:/vmeng... 4140 200 7081

2 0080413004732 46 GET http: /v g... 4375 200 074 1000 A £ 1000
2 0080413004732 4410 GET http: /v g 4406 20 et

FA] 0080413004732 45 GET http: /v g 4734 200 074 sp0 L =0
) 20080413 004732 47 GET http: /v g.. 4828 200 6314

] 0080413004732 49 GET http:/veweng... 4859 200 7081 2 2

% 0050413004732 417 GET hittp: /A g... 5031 200 7074 = T T Te T T o T T T

27 0050413004732 4418 GET http: /v g.. 5078 20 7074 BT

% 0080413004732 37 GET http: /v g... 5312 200 £314 - Number Of Responses

el ANNENAAINNAT- T2 AR GET hbtee Mhansin a FIRQ N0 TN7A

Rysunek 16 Przyktadowe raporty

Opisywane powyzej mozliwosci OpenSta sg tylko opisem tworzenia prostego scenariusza testowego.
Moga one by¢ rozbudowywane poprzez dodawanie nowych funkcji w kodzie oraz poprzez zmiane
ustawien konfiguracyjnych testéw. Podczas wykonywania testdw niestety nie widzimy, jak program
,chodzi” po stronach, gdyz wszystkie operacje wykonywane sg w tle.

Jak kazdy program takze OpenSta nie jest bez wad. Kilka z nich, ktére poznatem chciatbym opisac.
Jedng z wad jest fakt, iz program nie zawsze chce nagrywac po HTTPS — w sytuacji wystgpienia
takiego problemu pozostaje nam nagranie po http i potem zmiana w kodzie na HTTPS lub ponowne
nagrywanie. Spowodowane jest to btedami podczas tworzenia programu i jak doczytatem na forum
problem ten ma znikng¢ w kolejnej wersji OpenSta. Kolejnym btedem jest fakt, ze nieraz po
uruchomieniu przegladarki nie chce wyswietla¢ nam zadnej strony. Spowodowane jest to serwerem,
ktory wpisuje sobie swoje Proxy na czas uruchamiania programu. Nalezy wtedy ponownie ustawic
serwer Proxy, jak na zatgczonych powyzej obrazkach. Innym btedem, jaki wychwycitem byt problem z
dtugoscia znakdéw podczas nagrywania skryptu. Z tego powodu kompilacja nie byta mozliwa. Jako ze
mamy podane linie, w ktorych sg te btedy, pozostaje nam skrécenie tego stringa ( ja miatem problem
z wersjami przegladarek , skrécitem tylko do IE 7 i problem zostat wyeliminowany — String "User-
Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Mozilla/4.0 (compatible; MSIE 6.0;
Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; InfoPath.2; MEGAUPLOAD 2.0; .NET CLR 2.0.50727)").

Podsumowanie

Podsumowujgc uwazam, ze mimo pewnych wad jest to godny polecenia, szybko dziatajacy,
posiadajgcy duzo mozliwosci i ciggle rozwijany program do mierzenia wydajnosci. Programy takiego
typu utatwiajg mi prace i podczas testowania aplikacji zawsze zastanawiam sie, jak mozna by
wykorzystaé jakis program, aby zautomatyzowac testy aplikacji, a gdy juz mam to gotowe pozostaje
mi myslenie nad optymalizacjg. Chetnych do pogtebiania wiedzy na temat tego programu odsytam do
literatury:

http://www.opensta.org/

http://portal.opensta.org/
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